Twitter Facebook RSS

Accueil > GNU/Linux, Planet-libre, MySQL > Mise à jour Squeeze vers Wheezy : MySQL DotDeb

08
juillet

Mise à jour Squeeze vers Wheezy : MySQL DotDeb

Allez, le petit article du mois.. Enfin, devrais-je dire le tip ? Sûrement, ce sera un article assez court :

Ce week-end, j'ai voulu mettre à jour mon serveur sous Squeeze en Wheezy, la dernière version stable de Debian.

Hop, on modifie le sources.list, on remplace squeeze par wheezy, et on lance nos commandes magiques :

apt-get update
apt-get ugprade
apt-get dist-upgrade

Mais l'upgrade renvoie cette erreur :

Souhaitez-vous continuer [O/n] ? O
(Lecture de la base de données... 23335 fichiers et répertoires déjà installés.)
Préparation du remplacement de mysql-client-5.5 5.5.31-1~dotdeb.0 (en utilisant .../mysql-client-5.5_5.5.31+dfsg-0+wheezy1_amd64.deb) ...
Dépaquetage de la mise à jour de mysql-client-5.5 ...
dpkg : erreur de traitement de /var/cache/apt/archives/mysql-client-5.5_5.5.31+dfsg-0+wheezy1_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/bin/mysqlcheck », qui appartient aussi au paquet mysql-client-core-5.5 5.5.31-1~dotdeb.0
configured to not write apport reports
                                      dpkg-deb: sous-processus coller tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/mysql-client-5.5_5.5.31+dfsg-0+wheezy1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

On dirait que mon serveur essaye d'écraser le paquet mysql-client-5.5 de Dotdeb par celui de Wheezy...

Une solution qui marche serait de virer totalement MySQL et de le réinstaller... Mouais, bof.

Je préfère cette solution :

apt-get -f install -o Dpkg::Options::=”–force-overwrite”
apt-get remove mysql-client-core-5.5
apt-get dist-upgrade

Et là ça marche, MySQL est bien mis à jour par celui de Dotdeb.

:

#1 - Le jeudi 25 juillet 2013 @ 23:31 gilles a dit

cette solution ne marche pas !!

premiere commande et direct une erreur : "E: Sub-process /usr/bin/dpkg returned an error code (2)"

#2 - Le dimanche 01 septembre 2013 @ 12:51 Gimly a dit

En effet, la manière dont est marqué la premiere commande n'est pas dans le bon sens, voici la commande qui foncitonne :

apt-get -o Dpkg::Options::="--force-overwrite" install -f

Les commentaires sont fermés.

^ Retourner en haut